Subject: rev 31 - trunk trunk/www

From: [email-masked]
Date: Mon, 7 Oct 2002 08:07:07 -0500

Author: loredana
Date: 2002-10-07 08:07:02 -0500 (Mon, 07 Oct 2002)
New Revision: 31

Modified:
   trunk/Makefile.in
   trunk/configure.in
   trunk/www/index.html.in
Log:
   * configure.in
     (SVN_REPOSITORY_VERSION): added local svn revision number

   * Makefile.in
     (dist): DISTDIR and the tarball filename include SVN_REPOSITORY_VERSION
     
   * www/index.html.in modified to reflect changes

Modified: trunk/Makefile.in
==============================================================================
--- trunk/Makefile.in	(original)
+++ trunk/Makefile.in	Mon Oct  7 08:07:06 2002
@@ -9,6 +9,7 @@
 CFLAGS = @CFLAGS@
 
 VERSION=@VERSION@
+SVN_REPOSITORY_VERSION=@SVN_REPOSITORY_VERSION@
 ARCHITECTURE=@ARCHITECTURE@
 
 # PREFIXDIR is the "top level" directory in which to place the
@@ -46,7 +47,7 @@
 
 ### You should not need to modify anything below this line.
 SOURCE_DIRS=phylo readers analyses lisp docs
-DISTDIR=ale-${VERSION}
+DISTDIR=ale-${VERSION}-${SVN_REPOSITORY_VERSION}
 VC_SUBDIR=.svn
 
 all: ale lisp/gene-version.el

Modified: trunk/www/index.html.in
==============================================================================
--- trunk/www/index.html.in	(original)
+++ trunk/www/index.html.in	Mon Oct  7 08:07:06 2002
@@ -18,7 +18,7 @@
 Ale is an alignment editor for genetic sequences.  It
 
 <ul>
-<li>Supports nucleic and amino sequences,</li>
+<li>Supports nucleic and amino acid sequences,</li>
 <br>
 <li>Provides a powerful vocabulary of alignment manipulation commands,</li>
 <br>
@@ -61,8 +61,8 @@
 Also, you can:
 
 <ul>
-  <li><a href="ale-@VERSION@.tar.gz"
-      >Download prepackaged source code to Ale @VERSION@.</a>
+  <li><a href="ale-@VERSION@-@SVN_REPOSITORY_VERSION@.tar.gz"
+      >Download prepackaged source code to Ale @VERSION@ svn @SVN_REPOSITORY_VERSION@.</a>
   </li>
 <br>
   <li><a href="http://svn.red-bean.com:8080/ale/trunk/"

Modified: trunk/configure.in
==============================================================================
--- trunk/configure.in	(original)
+++ trunk/configure.in	Mon Oct  7 08:07:06 2002
@@ -9,6 +9,9 @@
 AC_SUBST(VERSION)
 VERSION=0.1.188
 
+AC_SUBST(SVN_REPOSITORY_VERSION)
+SVN_REPOSITORY_VERSION=`svn st -vN . | head -1 | awk '{print $2}`
+
 dnl Find Emacs, and 
 AC_PATH_PROG(EMACS,emacs)
 
@@ -50,3 +53,5 @@
              phylo/Makefile
            readers/Makefile
                www/index.html)
+
+AC_MSG_WARN(Using Ale version $VERSION and local svn copy n. $SVN_REPOSITORY_VERSION)

---

From: Karl Fogel <[email-masked]>
Date: 09 Oct 2002 11:36:26 -0500

>    * www/index.html.in modified to reflect changes

Neat!  I like this change.

You might want to add in some safeguard against a
mixed-working-revision working copy.

Also, is there any reason to keep the VERSION variable in configure
anymore, as separate from SVN_REPOSITORY_VERSION?  Or rather, keep
the name VERSION, but make your change to it directly in configure.in:

   VERSION=`svn st -vN . | head -1 | awk '{print $2}`

?

Just a thought,
-Karl

---

From: Loredana Lo Conte <[email-masked]>
Date: Thu, 10 Oct 2002 00:05:10 +0100 (BST)

> Neat!  I like this change.
:)

What I don't like is that I had to use AC_CHECK_PROG to set
the svn version based on the "existence" of svn because it
complains if I use AC_CHECK_FILE (with .svn, that it would
make more sense). See rev 32.

> mixed-working-revision working copy.

I never wtore a configure.in file, need to figure out what it is, how
it works (done) and the language (todo).

>    VERSION=`svn st -vN . | head -1 | awk '{print $2}`
Perhaps a reason is that with a decimal notation it is easier to mark
important changes, from 0.xxx to 1.xxx? Don't know. I expect Ale to
evolve :)

Loredana