[Lispweb] Problem installing portableaserve

John Pontious pontious at interhack.net
Tue Mar 12 09:04:35 CST 2002


I am hoping someone out there can point me in the general right 
direction.  I am haing a problem getting the Portable AllegroServe 
working.  

I am running FreeBSD 4.5, cmucl 18c, the latest bulding of CLOCC, and a 
very recent version of portableaserve from the cvs repository at 
sourceforge.

I have loaded various things from time to time in my .cmucl-init, from 
everything in clocc/src/ports and clocc/src/cllib + defsystem and my 
cmucl gray-streams, to currently defsystem and the gray-streams stuff.

On with my problem....

I eval (load "INSTALL.lisp") in the portableaserve directory, it goes 
along fine compiling stuff and so on, then it finally comes back with 
this error message:

Error in function COMMON-LISP::FOREIGN-SYMBOL-ADDRESS-AUX:
   Unknown foreign symbol: "setuid" 

If I exit out and come back I get a much briefer interaction with the 
top level (stuff is already compiled..) and the whole mess looks like this:


Warning:  Declaring *CLOCC-ROOT* special.
;; Loading #p"/usr/local/src/clocc/clocc.x86f".
;; Loading #p"/usr/local/src/clocc/src/defsystem-3.x/defsystem.x86f".
;; Loading 
#p"/usr/local/lib/cmucl/lib/subsystems/gray-streams-library.x86f".
Compiling LAMBDA (#:G864 #:G865 #:G868 #:G869):
Compiling Top-Level Form:
Compiling LAMBDA (#:G878 #:G879 #:G881 #:G882):
Compiling Top-Level Form:
CMU Common Lisp 18c, running on aragorn.406sherwoodforest.us
Send questions and bug reports to your local CMU CL maintainer,
or to cmucl-help at cons.org. and cmucl-imp at cons.org. respectively.
Loaded subsystems:
    Python 1.0, target Intel x86
    CLOS based on PCL version:  September 16 92 PCL (f)
* (load "INSTALL.lisp")

; Loading #p"/usr/home/jmp/lisp/portableaserve/INSTALL.lisp".
;; Loading 
#p"/usr/local/lib/cmucl/lib/subsystems/gray-streams-library.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/logical-hostnames.lisp".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-compat.system".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/acl-compat/nregex.x86f".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-mp-package.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-mp-cmu.x86f".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-socket-cmu.x86f".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-excl-cmu.x86f".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/acl-compat/acl-sys-cmu.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/acl-compat/meta.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/acl-compat/uri.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/acl-compat/chunked.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/aserve/aserve.system".
;; Loading 
#p"/usr/home/jmp/lisp/portableaserve/aserve/htmlgen/htmlgen.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/aserve/macs.x86f".
;; Loading #p"/usr/home/jmp/lisp/portableaserve/aserve/main.x86f".


Error in function COMMON-LISP::FOREIGN-SYMBOL-ADDRESS-AUX:
   Unknown foreign symbol: "setuid"

Restarts:
  0: [CONTINUE] Return NIL from load of 
"/usr/home/jmp/lisp/portableaserve/aserve/main.x86f".
  1:            Return NIL from load of "INSTALL.lisp".
  2: [ABORT   ] Return to Top-Level.

Debug  (type H for help)

(COMMON-LISP::FOREIGN-SYMBOL-ADDRESS-AUX "setuid")
0]



I have run out of ideas.   Any help would be appreciated.

--pontious




More information about the lispweb mailing list