[svnbook] r5242 committed - branches/1.8/vi/book/ch01-fundamental-concepts. xml

Daniel Shahaf d.s at daniel.shahaf.name
Thu Dec 1 02:15:44 CST 2016

Chinh Do wrote on Thu, Dec 01, 2016 at 08:53:15 +0700:
> Hi Mike,
> Yes, these seam to be something wrong with svn
> *svnversion: E155036: The working copy at
> '/Volumes/DATA/working/OCB/TIO/Version-Control-with-Subversion_vi/vi'*
> *is too old (format 29) to work with client version '1.9.4 (r1740329)'
> (expects format 31). You need to upgrade the working copy first.*

This means the working copy was checked out with a 1.7 client, but your
svnversion is version 1.8 or 1.9.  Do you still have a 1.7 client on
your system?  (Check the version of the client you commit/update with.)
If not, then it's safe to run 'svn upgrade' with 1.8 or 1.9.

(Is this documented in the book?  I found just one example, in the
appendix, and it doesn't even warn about the multiple-clients scenario.)

In any case, if you update to r5253 and rebuild ('make clean all valid',
I guess?), then xmllint should report the actual problem, even if you
don't fix the svnversion 29/31 mismatch first.



More information about the svnbook-dev mailing list